Posted by & filed under cPanel, Security.

SUMMARY
cPanel, Inc. has updated RPMs for EasyApache 4 with PHP versions 5.6.32, 7.0.25 and 7.1.11, and released EasyApache 3.34.19 with PHP version 5.6.32 on October 31, 2017. This release addresses vulnerabilities related to CVE-2016-1283. We strongly encourage all PHP 5.6 users to upgrade to versions 5.6.32, all PHP 7.0 users to upgrade to version 7.0.25, and all PHP 7.1 users to upgrade to version 7.1.11.

 

AFFECTED VERSIONS
All versions of PHP 5.6 through 5.6.31
All versions of PHP 7.0 through 7.0.24
All versions of PHP 7.1 through 7.1.10

 

SECURITY RATING
The National Vulnerability Database (NIST) has given the following severity ratings to these CVEs:

CVE-2016-1283 – HIGH
PHP 5.6.32
Fixed bug in PCRE related to CVE-2016-1283

PHP 7.0.25
Fixed bug in PCRE related to CVE-2016-1283

PHP 7.1.11
Fixed bug in PCRE related to CVE-2016-1283

 

SOLUTION
cPanel, Inc. has released updated RPMs for EasyApache 4 on October 31, 2017, with a updated versions of PHP versions 5.6.32, 7.0.25, and 7.1.11. Unless you have enabled automatic RPM updates in your cron, update your system with either yum update or WHM’s Run System Update interface.

cPanel, Inc. has released EasyApache 3.34.19 with an updated versions of PHP 5.6.32. Unless you have disabled EasyApache updates, the EasyApache application updates to the latest version when launched. Run EasyApache to rebuild your profile with the latest version of PHP.

 

REFERENCES
https://nvd.nist.gov/vuln/detail/CVE-2016-1283
http://www.php.net/ChangeLog-5.php
http://www.php.net/ChangeLog-7.php

Comments are closed.